Plesk Fehler /run/lock/lmlib/SharedLockManagerStorage0.2.4 8388608 error

Der Strato Server ist auch per SSH nicht mehr erreichbar, was die Reparatur deutlich erschwert.

Mal vorweg:
Die HOTLINE von Strato ist eine Katastrophe!
Während mir der erste Anruf zumindest einen (unvollständigen halbherzigen) Workaround per Email einbrachte, hat der zweite Anruf noch weniger gebracht. Gefühltes Achselzucken am anderen Ende der Leitung und ein stetiges Wiederholen von, da können wir nicht helfen….

Das grösste Problem an dieser Sache ist ja, dass der SSH Zugang nicht mehr funktioniert, weil aus irgendeinem Grund Plesk dafür sorgt, dass dieser nicht gestartet wird

 

Man kommt nur noch über das RESCUE System an seinen Server.
Eine tatsächlich (bei mir) funktionierende Lösung war es, zunächst den SSH Zugang wieder herzustellen und danach Plesk zu reparieren.
Mehrere Teillösungen hier zusammengebaut brachten dann den Erfolg.

 

Zuerst starten wir das Rescue System von Strato:

Recovery Manager
Hier können sie Ihren Server resetten und oder den Modus bestimmen zum Start

Dann bekommen wir ein temporäres Passwort und können uns später mit putty einloggen:

 

Das file rc.local editieren wir mit dem vi am besten direkt nach dem login mit dem Befehl:
# vi  /repair/etc/rc.local

Taste EINFÜGEN drücken und folgende Zeilen eingeben:

if [ ! -d /var/run/sshd ]; then
mkdir /var/run/sshd
chmod 0755 /var/run/sshd
systemctl enable ssh
fi
exit 0

 

Am Schluss einmal ESC drücken und dann im vi abspeichern mit =>   :wq      (= Doppelpunkt Speichern Beenden)

Danach noch diese beiden Befehle:

# chown root /repair/etc/rc.local
# chmod 0755 /repair/etc/rc.local

Dann den Server neu starten über die Recovery Console:
Nach dem Neustart müsste der alte SSH Zugang wieder funktionieren!

Einloggen als User und mit su auf den Admin stufen und dann zuerst das Problem der defekten Plesk Rechte lösen mit:

# mkdir -p /run/lock/lmlib && chown root:lock-manager /run/lock/lmlib && chmod -R 0770 /run/lock/lmlib

Besser ist es die Zeile fest in der Crontab einzutragen, also aufrufen mit:

# crontab -e

Dann folgende Zeile als erste Zeile eintragen:

@reboot mkdir -p /run/lock/lmlib && chown root:lock-manager /run/lock/lmlib && chmod -R 0770 /run/lock/lmlib

und dann abspeichern mit dem vi ?  Dann mit  ESC  :wq

Bei einigen Servern half auch zusätzlich dieser Befehl:

# plesk installer –select-release-current –reinstall-patch –upgrade-installed-components

Nach Abschluss dieser Vorgänge hat PLESK wieder funktioniert……  dachte ich, leider nur bis:


NACHTRAG:

Meine Kunden meldeten bei Abholung von E-Mails plötzlich einen Passwort / Benutzernamenfehler
Das Lesen von Emails über Horde / Webmail, ebenfalls Passwortfehler war nicht mehr möglich
Auch das Neuanlegen von Email – Adressen unter der PLESK Oberfäche erzeugte rote Felder mit Fehlermeldungen

Also nochmal auf die Komanndozeile per SSH / root habe ich dann folgenden Befehl probiert:

#plesk repair all -y

nach diesem Durchlauf, der durchaus einige Minuten dauern kann, waren die Email Fehler in der Oberfläche wieder beseitigt

 

 

 

Wenn Euch die Tipps helfen konnten, dann würde ich mich über Euren Kommentar freuen.

 

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.